diff options
author | Cara Salter <cara@devcara.com> | 2022-07-19 19:49:39 -0400 |
---|---|---|
committer | Cara Salter <cara@devcara.com> | 2022-07-19 19:49:39 -0400 |
commit | c742b752140ab0eee6e353c779bd897042ba6739 (patch) | |
tree | 58953fdcaedb7e6c458a29dd980b8f97fb1af2a7 /Cargo.toml | |
parent | 1bd04149f8f6133b817a37a37a91397750c76c1b (diff) | |
download | nccd-c742b752140ab0eee6e353c779bd897042ba6739.tar.gz nccd-c742b752140ab0eee6e353c779bd897042ba6739.zip |
Big login system
Still needs cookies, but those are coming! (and should be set anyways!)
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 5 |
1 files changed, 4 insertions, 1 deletions
@@ -9,7 +9,7 @@ build = "src/build.rs" [dependencies] axum = { version = "0.5.13", features = ["json", "tower-log"] } -axum-extra = { version = "0.3.6", features = ["spa"] } +axum-extra = { version = "0.3.6", features = ["spa", "cookie", "cookie-private"] } color-eyre = "0.6.2" hyper = { version = "0.14.20", features = ["full"] } serde = { version = "1.0.139", features = ["derive"] } @@ -22,6 +22,9 @@ tracing = "0.1.35" tracing-subscriber = { version = "0.3.14", features = ["env-filter"] } axum-macros = "0.2.3" chrono = "0.4.19" +ulid = "0.6.0" +async-session = "3.0.0" +bcrypt = "0.13.0" [dependencies.sqlx] version = "0.6" |