aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCara Salter <cara@devcara.com>2022-01-12 15:45:20 -0500
committerCara Salter <cara@devcara.com>2022-01-12 15:45:20 -0500
commit67e4081aa69f489ad88ee064402d68a5969069c2 (patch)
treec69b79679d35df650b684fa487b1725b3c211250 /Cargo.toml
parent6bc33b93eb5d55fb855803b0bf8cf7658a60e2b1 (diff)
downloadglitch-ng-67e4081aa69f489ad88ee064402d68a5969069c2.tar.gz
glitch-ng-67e4081aa69f489ad88ee064402d68a5969069c2.zip
rroles: Implement Reaction Roles
now requires postgresql.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 35907a2..e17a57c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -29,11 +29,15 @@ features = [
"model",
"standard_framework",
"utils",
+ "collector",
]
[dependencies.poise]
git = "https://github.com/kangalioo/poise"
branch = "master"
+features = [
+ "collector"
+ ]
[dependencies.tokio]
version = "1"
@@ -49,3 +53,14 @@ features = [ "derive" ]
[dependencies.serde_json]
version = "1"
+
+[dependencies.sqlx]
+version = "0.5"
+features = [
+ "runtime-tokio-rustls",
+ "postgres",
+ "uuid",
+ "chrono",
+ "migrate",
+ "macros",
+]