aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCara Salter <cara@devcara.com>2022-05-03 13:57:09 -0400
committerCara Salter <cara@devcara.com>2022-05-03 13:57:09 -0400
commit5999e6a803a7b848acf054918fec9ee5024d5697 (patch)
treeeae1f3986c41f7d7c1a956e4606a8120c6032e05 /Cargo.toml
parent8f4277c55a2079edf1c9a69383c353e1cb9ef55c (diff)
downloadglitch-ng-5999e6a803a7b848acf054918fec9ee5024d5697.tar.gz
glitch-ng-5999e6a803a7b848acf054918fec9ee5024d5697.zip
filter: Initial message filter implementation
Also a custom error type, tracing_subscriber, and unsafe impls
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 88342e4..a21e76d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,11 +12,18 @@ log = "0.4"
tracing = "0.1"
tracing-subscriber = "0.2"
+thiserror = "1"
+color-eyre = "0.6"
+
rand = "0.8"
reqwest = "0.11"
chrono = { version = "0.4", features = ["serde"] }
+regex = "1"
+
+futures = "0.3"
+
[dependencies.serenity]
git = "https://github.com/serenity-rs/serenity"
branch = "next"