aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 4673ed5..9963206 100644
--- a/flake.nix
+++ b/flake.nix
@@ -9,12 +9,17 @@
system: let
pkgs = nixpkgs.legacyPackages."${system}";
naersk-lib = naersk.lib."${system}";
+ deps = with pkgs; [
+ libvirt
+ ];
in
rec {
# `nix build`
packages.waifud = naersk-lib.buildPackage {
pname = "waifud";
root = ./.;
+ nativeBuildInputs = deps;
+ buildInputs = deps;
};
defaultPackage = packages.waifud;
@@ -71,7 +76,7 @@
# `nix develop`
devShell = pkgs.mkShell {
- nativeBuildInputs = with pkgs; [ rustc cargo ];
+ nativeBuildInputs = with pkgs; [ rustc cargo ] ++ deps;
};
}
);