diff options
author | Cara Salter <cara@devcara.com> | 2022-04-27 14:44:33 -0400 |
---|---|---|
committer | Cara Salter <cara@devcara.com> | 2022-04-27 14:44:33 -0400 |
commit | bc3132f22f3470d8b1d8189e23393d3bb4577480 (patch) | |
tree | b8d6466e4191a4e7e5e4a755102e82ffbff56b36 /flake.nix | |
parent | 9696669ff126cd2bcbc31e90651b464432b7947f (diff) | |
download | solard-bc3132f22f3470d8b1d8189e23393d3bb4577480.tar.gz solard-bc3132f22f3470d8b1d8189e23393d3bb4577480.zip |
List waifus
Also use environment variables and new error types
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 7 |
1 files changed, 6 insertions, 1 deletions
@@ -9,12 +9,17 @@ system: let pkgs = nixpkgs.legacyPackages."${system}"; naersk-lib = naersk.lib."${system}"; + deps = with pkgs; [ + libvirt + ]; in rec { # `nix build` packages.waifud = naersk-lib.buildPackage { pname = "waifud"; root = ./.; + nativeBuildInputs = deps; + buildInputs = deps; }; defaultPackage = packages.waifud; @@ -71,7 +76,7 @@ # `nix develop` devShell = pkgs.mkShell { - nativeBuildInputs = with pkgs; [ rustc cargo ]; + nativeBuildInputs = with pkgs; [ rustc cargo ] ++ deps; }; } ); |