summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 24 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4ae161d..29629f2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,8 +1,31 @@
[package]
name = "solarctl"
-version = "0.1.0"
+version = "0.2.0"
edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
+
+thiserror = "1"
+color-eyre = "0.6"
+eyre = "0.6"
+
+tabular = "0.2"
+
+[dependencies.solarlib]
+git = "https://git.carathe.dev/solard/solarlib"
+branch = "master"
+
+[dependencies.clap]
+version = "3"
+features = [
+ "derive"
+]
+
+[dependencies.reqwest]
+version = "0.11"
+features = [
+ "blocking",
+ "json"
+]