diff options
author | Cara Salter <cara@devcara.com> | 2022-06-09 15:03:13 -0400 |
---|---|---|
committer | Cara Salter <cara@devcara.com> | 2022-06-09 15:03:13 -0400 |
commit | 0b82b7b47ac34cb9a14613a83ce6eb386ae21086 (patch) | |
tree | 5d41dea764838f004431c5d8bb755eaa28d2ee67 /flake.nix | |
parent | 7f2bb3c132c9ef65aeb878cf71c14db12c7b801f (diff) | |
download | solarctl-0b82b7b47ac34cb9a14613a83ce6eb386ae21086.tar.gz solarctl-0b82b7b47ac34cb9a14613a83ce6eb386ae21086.zip |
state: Add shutdown/start/pause manipulation
issue #1
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 21 |
1 files changed, 14 insertions, 7 deletions
@@ -9,24 +9,31 @@ system: let pkgs = nixpkgs.legacyPackages."${system}"; naersk-lib = naersk.lib."${system}"; + + deps = with pkgs; [ + openssl + pkg-config + libvirt + ]; in rec { # `nix build` - packages.hello-world = naersk-lib.buildPackage { - pname = "hello-world"; + packages.solarctl = naersk-lib.buildPackage { + pname = "solarctl"; root = ./.; + nativeBuildInputs = deps; }; - defaultPackage = packages.hello-world; + defaultPackage = packages.solarctl; # `nix run` - apps.hello-world = flake-utils.lib.mkApp { - drv = packages.hello-world; + apps.solarctl = flake-utils.lib.mkApp { + drv = packages.solarctl; }; - defaultApp = apps.hello-world; + defaultApp = apps.solarctl; # `nix develop` devShell = pkgs.mkShell { - nativeBuildInputs = with pkgs; [ rustc cargo ]; + nativeBuildInputs = with pkgs; [ rustc cargo ] ++ deps; }; } ); |