summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorCara Salter <cara@devcara.com>2022-07-09 18:54:49 -0400
committerCara Salter <cara@devcara.com>2022-07-09 18:54:49 -0400
commitf7aedd98bff7b208da8dd70917fcf57fc140f0b7 (patch)
tree235a8bfcd321cf203fee2f2a9c5449b6030d9fc1 /flake.nix
parentd6ed1d4ad337a9e120e583fe91882b73e2e2d700 (diff)
downloadsolarctl-master.tar.gz
solarctl-master.zip
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/flake.nix b/flake.nix
deleted file mode 100644
index 3dff665..0000000
--- a/flake.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-{
- inputs = {
- flake-utils.url = "github:numtide/flake-utils";
- naersk.url = "github:nix-community/naersk";
- };
-
- outputs = { self, nixpkgs, flake-utils, naersk }:
- flake-utils.lib.eachDefaultSystem (
- system: let
- pkgs = nixpkgs.legacyPackages."${system}";
- naersk-lib = naersk.lib."${system}";
-
- deps = with pkgs; [
- openssl
- pkg-config
- libvirt
- ];
- in
- rec {
- # `nix build`
- packages.solarctl = naersk-lib.buildPackage {
- pname = "solarctl";
- root = ./.;
- nativeBuildInputs = deps;
- };
- defaultPackage = packages.solarctl;
-
- # `nix run`
- apps.solarctl = flake-utils.lib.mkApp {
- drv = packages.solarctl;
- };
- defaultApp = apps.solarctl;
-
- # `nix develop`
- devShell = pkgs.mkShell {
- nativeBuildInputs = with pkgs; [ rustc cargo ] ++ deps;
- };
- }
- );
-}