summaryrefslogtreecommitdiff
path: root/nix/rust.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/rust.nix')
-rw-r--r--nix/rust.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/nix/rust.nix b/nix/rust.nix
new file mode 100644
index 0000000..1419ec7
--- /dev/null
+++ b/nix/rust.nix
@@ -0,0 +1,10 @@
+{ sources ? import ./sources.nix }:
+
+let
+ pkgs =
+ import sources.nixpkgs { overlays = [ (import sources.nixpkgs-mozilla) ]; };
+ channel = "nightly";
+ date = "2022-02-16";
+ targets = [ ];
+ chan = pkgs.rustChannelOfTargets channel date targets;
+in chan