summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 17 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d4b8657..ae5ffa0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,16 +2,32 @@
name = "site"
version = "0.1.0"
edition = "2021"
+build = "src/build.rs"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
warp = "0.3"
comrak = "0.12"
-ructe = "0.13"
color-eyre = "0.5"
kankyo = "0.3"
+tracing = "0.1"
+chrono = "0.4"
+thiserror = "1"
+serde_yaml = "0.8"
+glob = "0.3"
+
+[build-dependencies]
+ructe = { version = "0.13", features = ["warp03"] }
+
+[dependencies.tracing-subscriber]
+version = "0.3"
+features = ["fmt"]
[dependencies.tokio]
version = "1"
features = ["full"]
+
+[dependencies.serde]
+version = "1"
+features = ["derive"]