summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorCara Salter <cara@devcara.com>2022-02-28 09:34:37 -0500
committerCara Salter <cara@devcara.com>2022-02-28 09:34:37 -0500
commitd6126294bf27c93e0f05cbd3129e9b20493db6d0 (patch)
tree9643f07b01d05449ca9fdcfb5b9076b747f7a5e8 /shell.nix
parenta610350e7e012a790e63fb86cbcb61effb041105 (diff)
downloadsite-d6126294bf27c93e0f05cbd3129e9b20493db6d0.tar.gz
site-d6126294bf27c93e0f05cbd3129e9b20493db6d0.zip
Nix and updated templates
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..dfd7db7
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,16 @@
+{ pkgs ? import <nixpkgs> {} }:
+
+let
+ sources = import ./nix/sources.nix;
+ pkgs = import sources.nixpkgs {};
+ rust = import ./nix/rust.nix { inherit sources; };
+in
+pkgs.mkShell {
+ buildInputs = [
+ pkgs.hello
+ rust
+
+ # keep this line if you use bash
+ pkgs.bashInteractive
+ ];
+}