aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml50
1 files changed, 0 insertions, 50 deletions
diff --git a/Cargo.toml b/Cargo.toml
deleted file mode 100644
index 60187f6..0000000
--- a/Cargo.toml
+++ /dev/null
@@ -1,50 +0,0 @@
-[package]
-name = "nccd"
-version = "0.1.0"
-edition = "2021"
-
-build = "src/build.rs"
-
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
-[dependencies]
-axum = { version = "0.5.13", features = ["json", "tower-log"] }
-axum-extra = { version = "0.3.6", features = ["spa", "cookie", "cookie-private", "cookie-signed"] }
-color-eyre = "0.6.2"
-hyper = { version = "0.14.20", features = ["full"] }
-serde = { version = "1.0.139", features = ["derive"] }
-thiserror = "1.0.31"
-tokio = { version = "1.20.0", features = ["full"] }
-toml = "0.5.9"
-tower = { version = "0.4.13", features = ["util", "timeout"] }
-tower-http = { version = "0.3.4", features = ["add-extension", "trace"] }
-tracing = "0.1.35"
-tracing-subscriber = { version = "0.3.14", features = ["env-filter"] }
-axum-macros = "0.2.3"
-chrono = "0.4.19"
-ulid = "0.6.0"
-async-session = "3.0.0"
-bcrypt = "0.13.0"
-ipnetwork = "0.20.0"
-lettre = { version = "0.10.1", features = ["tokio1", "tracing", "tokio1-native-tls"] }
-
-[dependencies.sqlx]
-version = "0.6"
-features = [
- "postgres",
- "ipnetwork",
- "chrono",
- "runtime-tokio-rustls"
- ]
-
-
-[dependencies.ructe]
-version = "0.14"
-features = [
- "sass"
-]
-[build-dependencies.ructe]
-version = "0.14"
-features = [
- "sass"
-]