aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCara Salter <cara@devcara.com>2022-07-19 12:49:28 -0400
committerCara Salter <cara@devcara.com>2022-07-19 12:49:28 -0400
commitaadc1975d459f0e2e2807dbb3e2a36098476128b (patch)
tree231efcabf21f95e46ae5ffdedadf55bf3ccea66b /Cargo.toml
downloadnccd-aadc1975d459f0e2e2807dbb3e2a36098476128b.tar.gz
nccd-aadc1975d459f0e2e2807dbb3e2a36098476128b.zip
Initial commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml45
1 files changed, 45 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..9a08b4a
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,45 @@
+[package]
+name = "nccd"
+version = "0.1.0"
+edition = "2021"
+
+build = "src/build.rs"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+axum = { version = "0.5.13", features = ["json", "tower-log"] }
+axum-extra = { version = "0.3.6", features = ["spa"] }
+color-eyre = "0.6.2"
+hyper = { version = "0.14.20", features = ["full"] }
+serde = { version = "1.0.139", features = ["derive"] }
+thiserror = "1.0.31"
+tokio = { version = "1.20.0", features = ["full"] }
+toml = "0.5.9"
+tower = { version = "0.4.13", features = ["util", "timeout"] }
+tower-http = { version = "0.3.4", features = ["add-extension", "trace"] }
+tracing = "0.1.35"
+tracing-subscriber = { version = "0.3.14", features = ["env-filter"] }
+axum-macros = "0.2.3"
+chrono = "0.4.19"
+
+[dependencies.sqlx]
+version = "0.6"
+features = [
+ "postgres",
+ "ipnetwork",
+ "chrono",
+ "runtime-tokio-rustls"
+ ]
+
+
+[dependencies.ructe]
+version = "0.14"
+features = [
+ "sass"
+]
+[build-dependencies.ructe]
+version = "0.14"
+features = [
+ "sass"
+]