aboutsummaryrefslogtreecommitdiff
path: root/installer.spec
diff options
context:
space:
mode:
authorDylan Jones <dylanjones2011@gmail.com>2020-12-13 16:33:09 -0500
committerDylan Jones <dylanjones2011@gmail.com>2020-12-13 16:33:09 -0500
commita18a7161690d6c9b8560375aeea2ba2f66277b40 (patch)
treeed947738ecca8a36c25362dcd42a0165b73c230f /installer.spec
parentc1414c043ee8abd9dbbaa522bc770467750b047f (diff)
downloadmodpackman-a18a7161690d6c9b8560375aeea2ba2f66277b40.tar.gz
modpackman-a18a7161690d6c9b8560375aeea2ba2f66277b40.zip
actually add chisel and bits
Diffstat (limited to 'installer.spec')
-rw-r--r--installer.spec48
1 files changed, 48 insertions, 0 deletions
diff --git a/installer.spec b/installer.spec
new file mode 100644
index 0000000..dca793c
--- /dev/null
+++ b/installer.spec
@@ -0,0 +1,48 @@
+# -*- mode: python ; coding: utf-8 -*-
+import os
+import sys
+
+# included data is based on cwd
+cwd = os.getcwd()
+pack_name = cwd.split(os.path.sep)[-1]
+j = os.path.join
+
+block_cipher = None
+
+
+a = Analysis(['installer.py'],
+ pathex=[cwd],
+ binaries=[],
+ datas=[
+ (j(cwd, 'pack-lock.ini'), '.'),
+ (j(cwd, 'pack.ini'), '.'),
+ (j(cwd, 'icon.png'), '.'),
+ (j(cwd, 'config'), 'config')
+ ],
+ hiddenimports=[],
+ hookspath=[],
+ runtime_hooks=[],
+ excludes=[],
+ win_no_prefer_redirects=False,
+ win_private_assemblies=False,
+ cipher=block_cipher,
+ noarchive=False)
+
+pyz = PYZ(a.pure, a.zipped_data,
+ cipher=block_cipher)
+
+exe = EXE(pyz,
+ a.scripts,
+ a.binaries,
+ a.zipfiles,
+ a.datas,
+ [],
+ name=f'{pack_name}-installer',
+ debug=False,
+ bootloader_ignore_signals=False,
+ strip=False,
+ upx=True,
+ upx_exclude=[],
+ runtime_tmpdir=None,
+ console=True,
+ icon=j(cwd, 'icon.ico') + ",0")