summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCara Salter <cara@devcara.com>2023-03-26 12:05:27 -0400
committerCara Salter <cara@devcara.com>2023-03-26 12:05:27 -0400
commitb59b5a9bcbc64902366f6da21c84cb20be61efb8 (patch)
treeae5dcf03ebfd4b9f7ff26e54195b4d31317b0597 /Cargo.toml
downloadmodpackman-ng-b59b5a9bcbc64902366f6da21c84cb20be61efb8.tar.gz
modpackman-ng-b59b5a9bcbc64902366f6da21c84cb20be61efb8.zip
initial commitHEADmaster
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..9955c1d
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,36 @@
+[package]
+name = "modpackman-ng"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+toml = "0.7"
+
+thirtyfour = "0.31" # Selenium
+
+thiserror = "1"
+
+# Logging
+color-eyre = "0.6"
+eyre = "0.6"
+
+tracing = "0.1"
+tracing-subscriber = { version = "0.3", features = [ "env-filter" ] }
+
+urlencoding = "2"
+
+
+# CLI
+[dependencies.clap]
+version = "4"
+features = ["derive"]
+
+[dependencies.serde]
+version = "1"
+features = ["derive"]
+
+[dependencies.tokio]
+version = "1"
+features = ["full"] \ No newline at end of file