summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 4764b03..d1f211b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -9,12 +9,18 @@
system: let
pkgs = nixpkgs.legacyPackages."${system}";
naersk-lib = naersk.lib."${system}";
+
+ deps = with pkgs; [
+ libvirt
+ ];
in
rec {
# `nix build`
packages.homeworld = naersk-lib.buildPackage {
pname = "homeworld";
root = ./.;
+ nativeBuildInputs = deps;
+ buildInputs = deps;
};
defaultPackage = packages.homeworld;
@@ -26,7 +32,7 @@
# `nix develop`
devShell = pkgs.mkShell {
- nativeBuildInputs = with pkgs; [ rustc cargo ];
+ nativeBuildInputs = with pkgs; [ rustc cargo ] ++ deps;
};
}
);