summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorCara Salter <cara@devcara.com>2022-05-27 23:35:22 -0400
committerCara Salter <cara@devcara.com>2022-05-27 23:35:22 -0400
commitccdcc1891b01b43069991cf58a588145b7559090 (patch)
tree347040d20aff34f3482b50aca26e6b9a1fb438fa /flake.nix
parent372b484e8a6366346d52ff44bbdaa6aad1cc2daa (diff)
downloadhomeworld-ccdcc1891b01b43069991cf58a588145b7559090.tar.gz
homeworld-ccdcc1891b01b43069991cf58a588145b7559090.zip
meta: API Scaffold
Initial implementation of a CRUD API for Ships. Should probably at some point support getting specific Ships based on something like shasum or an ID, so that solard can more easily pull it down
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 4764b03..d1f211b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -9,12 +9,18 @@
system: let
pkgs = nixpkgs.legacyPackages."${system}";
naersk-lib = naersk.lib."${system}";
+
+ deps = with pkgs; [
+ libvirt
+ ];
in
rec {
# `nix build`
packages.homeworld = naersk-lib.buildPackage {
pname = "homeworld";
root = ./.;
+ nativeBuildInputs = deps;
+ buildInputs = deps;
};
defaultPackage = packages.homeworld;
@@ -26,7 +32,7 @@
# `nix develop`
devShell = pkgs.mkShell {
- nativeBuildInputs = with pkgs; [ rustc cargo ];
+ nativeBuildInputs = with pkgs; [ rustc cargo ] ++ deps;
};
}
);