diff options
author | Cara Salter <cara@devcara.com> | 2022-05-27 23:13:52 -0400 |
---|---|---|
committer | Cara Salter <cara@devcara.com> | 2022-05-27 23:13:52 -0400 |
commit | 372b484e8a6366346d52ff44bbdaa6aad1cc2daa (patch) | |
tree | 29b9f5c2dcd07c54057fc86a8f0cc5861b8c0a6d /Cargo.toml | |
parent | ca5c737f047119f31e42a8700b8ae1ad4fabd17a (diff) | |
download | homeworld-372b484e8a6366346d52ff44bbdaa6aad1cc2daa.tar.gz homeworld-372b484e8a6366346d52ff44bbdaa6aad1cc2daa.zip |
initial axum scaffold
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 37 |
1 files changed, 37 insertions, 0 deletions
@@ -6,3 +6,40 @@ edition = "2021" # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html [dependencies] +tracing = "0.1" +tracing-subscriber = { version = "0.3", features = [ "env-filter" ] } + +tower = { version = "0.4", features = [ "util", "timeout" ] } +tower-http = { version = "0.3", features = [ "add-extension", "trace" ] } + +color-eyre = "0.6" +eyre = "0.6" + +thiserror = "1" + +kankyo = "0.3" + +[dependencies.solarlib] +git = "https://git.carathe.dev/solard/solarlib" +branch = "master" + +[dependencies.serde] +version = "1" +features = [ + "derive" +] + +[dependencies.axum] +version = "0.5" +features = [ + "json", + "tower-log" +] + +[dependencies.hyper] +version = "0.14" +features = [ "full" ] + +[dependencies.tokio] +version = "1" +features = [ "full" ] |