aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml51
1 files changed, 51 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..35907a2
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,51 @@
+[package]
+name = "glitch-ng"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+dotenv = "0.15"
+
+log = "0.4"
+tracing = "0.1"
+tracing-subscriber = "0.2"
+
+rand = "0.8"
+
+reqwest = "0.11"
+chrono = { version = "0.4", features = ["serde"] }
+
+[dependencies.serenity]
+version = "0.10"
+default-features = false
+features = [
+ "rustls_backend",
+ "cache",
+ "client",
+ "framework",
+ "gateway",
+ "model",
+ "standard_framework",
+ "utils",
+]
+
+[dependencies.poise]
+git = "https://github.com/kangalioo/poise"
+branch = "master"
+
+[dependencies.tokio]
+version = "1"
+features = [
+ "macros",
+ "signal",
+ "rt-multi-thread"
+]
+
+[dependencies.serde]
+version = "1"
+features = [ "derive" ]
+
+[dependencies.serde_json]
+version = "1"