aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCara Salter <cara@devcara.com>2022-01-16 13:30:47 -0500
committerCara Salter <cara@devcara.com>2022-01-16 13:30:47 -0500
commit4c804b3a85e2eee6dffc5a2bf0545814aaa12b95 (patch)
treefc261b2f2c4827027f9b6d19e1eef72c596e2130 /Cargo.toml
parenteb41fede91d072693b279f908976d2ebc2ba1ca3 (diff)
downloadglitch-ng-4c804b3a85e2eee6dffc5a2bf0545814aaa12b95.tar.gz
glitch-ng-4c804b3a85e2eee6dffc5a2bf0545814aaa12b95.zip
rroles: Implement add and del
Also abstract updating the menu into its own function
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 6 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e17a57c..44b16bc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,19 +18,22 @@ reqwest = "0.11"
chrono = { version = "0.4", features = ["serde"] }
[dependencies.serenity]
-version = "0.10"
+git = "https://github.com/serenity-rs/serenity"
+branch = "next"
default-features = false
features = [
"rustls_backend",
"cache",
"client",
- "framework",
"gateway",
"model",
- "standard_framework",
"utils",
"collector",
]
+[patch.crates-io.serenity]
+git = "https://github.com/serenity-rs/serenity"
+branch = "next"
+
[dependencies.poise]
git = "https://github.com/kangalioo/poise"