aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorCara Salter <cara@devcara.com>2022-04-12 12:22:19 -0400
committerCara Salter <cara@devcara.com>2022-04-12 12:29:32 -0400
commit34af52c58daae7ad75c0871e88e7b937fcd078fb (patch)
treebd1ca042e84efd708250595727db1a4bb76054e7 /flake.nix
downloadsolarlib-34af52c58daae7ad75c0871e88e7b937fcd078fb.tar.gz
solarlib-34af52c58daae7ad75c0871e88e7b937fcd078fb.zip
Initial commit
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..568bf22
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,38 @@
+{
+ inputs = {
+ flake-utils.url = "github:numtide/flake-utils";
+ naersk.url = "github:nix-community/naersk";
+ };
+
+ outputs = { self, nixpkgs, flake-utils, naersk }:
+ flake-utils.lib.eachDefaultSystem (
+ system: let
+ pkgs = nixpkgs.legacyPackages."${system}";
+ naersk-lib = naersk.lib."${system}";
+
+ build-inputs = with pkgs; [
+ libvirt
+ ];
+ in
+ rec {
+ # `nix build`
+ packages.waifulib = naersk-lib.buildPackage {
+ pname = "waifulib";
+ root = ./.;
+ buildInputs = build-inputs;
+ };
+ defaultPackage = packages.waifulib;
+
+ # `nix run`
+ apps.waifulib = flake-utils.lib.mkApp {
+ drv = packages.waifulib;
+ };
+ defaultApp = apps.waifulib;
+
+ # `nix develop`
+ devShell = pkgs.mkShell {
+ nativeBuildInputs = with pkgs; [ rustc cargo ] ++ build-inputs;
+ };
+ }
+ );
+}