summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCara Salter <cara@devcara.com>2022-06-09 15:03:13 -0400
committerCara Salter <cara@devcara.com>2022-06-09 15:03:13 -0400
commit0b82b7b47ac34cb9a14613a83ce6eb386ae21086 (patch)
tree5d41dea764838f004431c5d8bb755eaa28d2ee67 /Cargo.toml
parent7f2bb3c132c9ef65aeb878cf71c14db12c7b801f (diff)
downloadsolarctl-0b82b7b47ac34cb9a14613a83ce6eb386ae21086.tar.gz
solarctl-0b82b7b47ac34cb9a14613a83ce6eb386ae21086.zip
state: Add shutdown/start/pause manipulation
issue #1
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 24 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4ae161d..29629f2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,8 +1,31 @@
[package]
name = "solarctl"
-version = "0.1.0"
+version = "0.2.0"
edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
+
+thiserror = "1"
+color-eyre = "0.6"
+eyre = "0.6"
+
+tabular = "0.2"
+
+[dependencies.solarlib]
+git = "https://git.carathe.dev/solard/solarlib"
+branch = "master"
+
+[dependencies.clap]
+version = "3"
+features = [
+ "derive"
+]
+
+[dependencies.reqwest]
+version = "0.11"
+features = [
+ "blocking",
+ "json"
+]