diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 9 |
1 files changed, 9 insertions, 0 deletions
@@ -42,6 +42,11 @@ default = "/var/lib/homeworld/.env"; description = "The location of the environment file"; }; + services.homeworld.port = lib.mkOption { + type = lib.types.port; + default = 4000; + description = "The port that will be exposed"; + }; }; config = lib.mkIf config.services.homeworld.enable { @@ -92,6 +97,10 @@ }; services.postgresql.enable = true; + + networking.firewall.allowedTCPPorts = [ + config.services.homeworld.port + ]; }; }; |