aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1b2e67c..40edb5e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,8 @@ FetchContent_Declare(dpp
FetchContent_MakeAvailable(clog dpp)
+include(cmake/FindPCRE.cmake)
+
find_package(fmt)
string(ASCII 27 Esc)
@@ -24,7 +26,7 @@ aux_source_directory("src" coresrc)
add_executable(142bot ${coresrc})
include_directories("include")
-target_link_libraries(142bot clog dpp fmt spdlog)
+target_link_libraries(142bot clog dpp fmt spdlog pcre)
set (modules_dir "modules")
file(GLOB subdirlist ${modules_dir}/*)