aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCara Salter <cara@devcara.com>2023-03-27 11:53:41 -0400
committerCara Salter <cara@devcara.com>2023-03-27 11:53:41 -0400
commitc8befe7c95b18869f995c4f2cbc2f4cf9c91924f (patch)
treede1c309c0119ea2b101c65b2b040956873e2b48b /CMakeLists.txt
download142bot-c8befe7c95b18869f995c4f2cbc2f4cf9c91924f.tar.gz
142bot-c8befe7c95b18869f995c4f2cbc2f4cf9c91924f.zip
initial commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..001f41f
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,19 @@
+cmake_minimum_required(VERSION 3.0)
+project(142-bot VERSION 0.1 LANGUAGES CXX C)
+
+set(CMAKE_C_STANDARD 11 REQUIRED)
+
+include(FetchContent)
+FetchContent_Declare(clog
+ GIT_REPOSITORY https://git.devcara.com/clog
+ GIT_TAG 0.1.0
+)
+
+FetchContent_Declare(dpp
+ GIT_REPOSITORY https://github.com/brainboxdotcc/DPP
+ GIT_TAG v10.0.23
+)
+
+FetchContent_MakeAvailable(clog dpp)
+
+add_subdirectory(src)