aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCara Salter <cara@devcara.com>2023-04-06 15:45:39 -0400
committerCara Salter <cara@devcara.com>2023-04-06 17:11:52 -0400
commit7629de5b888bd3d1cdb94dce3ba51cb1e1c2e625 (patch)
tree0dd37a701fb242fa953c23f2b0a94252fa60762b /CMakeLists.txt
parentb66bf922cc2d8eb3a623d1f776ab6a144832f587 (diff)
download142bot-7629de5b888bd3d1cdb94dce3ba51cb1e1c2e625.tar.gz
142bot-7629de5b888bd3d1cdb94dce3ba51cb1e1c2e625.zip
pg: Add postgres support
Supports migrations Change-Id: Ifca8358d4f57a4b417f1d972e400e98767e01bb5
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5ac2947..f26e300 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,12 +33,16 @@ find_package(fmt)
string(ASCII 27 Esc)
+find_library(PQXX_LIB pqxx)
+find_library(PQ_LIB pq)
+
include(GNUInstallDirs)
aux_source_directory("src" coresrc)
add_executable(142bot ${coresrc})
include_directories("include")
-target_link_libraries(142bot PRIVATE clog dpp fmt::fmt spdlog::spdlog pcre cpr::cpr)
+target_link_libraries(142bot PRIVATE clog dpp fmt::fmt spdlog::spdlog pcre
+ cpr::cpr ${PQXX_LIB} ${PQ_LIB})
add_dependencies(142bot clog dpp cpr fmt spdlog)
install(TARGETS 142bot)