aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCara Salter <cara@devcara.com>2023-04-06 17:14:22 -0400
committerCara Salter <cara@devcara.com>2023-04-06 17:14:22 -0400
commit555810bedc0cf9d9d954f56b5a2c8c92522ad27f (patch)
tree0dd37a701fb242fa953c23f2b0a94252fa60762b /CMakeLists.txt
parent3a3a1e5345ae8e133fa7800d9fcba2dbb779b8b9 (diff)
parent7629de5b888bd3d1cdb94dce3ba51cb1e1c2e625 (diff)
download142bot-555810bedc0cf9d9d954f56b5a2c8c92522ad27f.tar.gz
142bot-555810bedc0cf9d9d954f56b5a2c8c92522ad27f.zip
Merge branch 'database'
Change-Id: I5f6fb3b64db0585955defdec0fe1ee9555ba89ec
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5ac2947..f26e300 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,12 +33,16 @@ find_package(fmt)
string(ASCII 27 Esc)
+find_library(PQXX_LIB pqxx)
+find_library(PQ_LIB pq)
+
include(GNUInstallDirs)
aux_source_directory("src" coresrc)
add_executable(142bot ${coresrc})
include_directories("include")
-target_link_libraries(142bot PRIVATE clog dpp fmt::fmt spdlog::spdlog pcre cpr::cpr)
+target_link_libraries(142bot PRIVATE clog dpp fmt::fmt spdlog::spdlog pcre
+ cpr::cpr ${PQXX_LIB} ${PQ_LIB})
add_dependencies(142bot clog dpp cpr fmt spdlog)
install(TARGETS 142bot)